# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.*)\s[A-Z]{2,}[0-9]{2}.*/$1/gm;t' <<< "C.H. Robinson o/Vienna SZO13G9, SZO6P34, Roger Moor
Bus Trans Mouse PT513AA, Anthony Hopkins
P.H.U TRI-POL ZMI14A8
Mank WXL89040, Jared Leto"