// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(.*)\s[A-Z]{2,}[0-9]{2}.*").unwrap();
let string = "C.H. Robinson o/Vienna SZO13G9, SZO6P34, Roger Moor
Bus Trans Mouse PT513AA, Anthony Hopkins
P.H.U TRI-POL ZMI14A8
Mank WXL89040, Jared Leto";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}