package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.*)\s[A-Z]{2,}[0-9]{2}.*`)
var str = `C.H. Robinson o/Vienna SZO13G9, SZO6P34, Roger Moor
Bus Trans Mouse PT513AA, Anthony Hopkins
P.H.U TRI-POL ZMI14A8
Mank WXL89040, Jared Leto`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}