const regex = /(.*)\s[A-Z]{2,}[0-9]{2}.*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*)\\s[A-Z]{2,}[0-9]{2}.*', 'gm')
const str = `C.H. Robinson o/Vienna SZO13G9, SZO6P34, Roger Moor
Bus Trans Mouse PT513AA, Anthony Hopkins
P.H.U TRI-POL ZMI14A8
Mank WXL89040, Jared Leto`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);