re = /(.*)\s[A-Z]{2,}[0-9]{2}.*/m
str = 'C.H. Robinson o/Vienna SZO13G9, SZO6P34, Roger Moor
Bus Trans Mouse PT513AA, Anthony Hopkins
P.H.U TRI-POL ZMI14A8
Mank WXL89040, Jared Leto'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result