#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(.*)\s[A-Z]{2,}[0-9]{2}.*"
Local $sString = "C.H. Robinson o/Vienna SZO13G9, SZO6P34, Roger Moor" & @CRLF & _
"Bus Trans Mouse PT513AA, Anthony Hopkins" & @CRLF & _
"P.H.U TRI-POL ZMI14A8" & @CRLF & _
"Mank WXL89040, Jared Leto"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)