# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(.*)\s[A-Z]{2,}[0-9]{2}.*"
test_str = ("C.H. Robinson o/Vienna SZO13G9, SZO6P34, Roger Moor\n"
"Bus Trans Mouse PT513AA, Anthony Hopkins\n"
"P.H.U TRI-POL ZMI14A8\n"
"Mank WXL89040, Jared Leto")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.