import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*)\\s[A-Z]{2,}[0-9]{2}.*";
final String string = "C.H. Robinson o/Vienna SZO13G9, SZO6P34, Roger Moor\n"
+ "Bus Trans Mouse PT513AA, Anthony Hopkins\n"
+ "P.H.U TRI-POL ZMI14A8\n"
+ "Mank WXL89040, Jared Leto";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}