#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^31\.13\.24\.0$|^31\.13\.24\.1$"
Local $sString = "31.13.24.0" & @CRLF & _
"31.13.24.1s" & @CRLF & _
"31.13.24.1" & @CRLF & _
"sda" & @CRLF & _
"31.13.24.1213"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")