import re
regex = re.compile(r"^31\.13\.24\.0$|^31\.13\.24\.1$", flags=re.MULTILINE)
test_str = ("31.13.24.0\n"
"31.13.24.1s\n"
"31.13.24.1\n"
"sda\n"
"31.13.24.1213")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")