// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^31\.13\.24\.0$|^31\.13\.24\.1$").unwrap();
let string = "31.13.24.0
31.13.24.1s
31.13.24.1
sda
31.13.24.1213";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}