const regex = /^31\.13\.24\.0$|^31\.13\.24\.1$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^31\\.13\\.24\\.0$|^31\\.13\\.24\\.1$', 'gm')
const str = `31.13.24.0
31.13.24.1s
31.13.24.1
sda
31.13.24.1213`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}