import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^31\\.13\\.24\\.0$|^31\\.13\\.24\\.1$";
final String string = "31.13.24.0\n"
+ "31.13.24.1s\n"
+ "31.13.24.1\n"
+ "sda\n"
+ "31.13.24.1213";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}