re = /^31\.13\.24\.0$|^31\.13\.24\.1$/m
str = '31.13.24.0
31.13.24.1s
31.13.24.1
sda
31.13.24.1213'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end