using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^31\.13\.24\.0$|^31\.13\.24\.1$";
string input = @"31.13.24.0
31.13.24.1s
31.13.24.1
sda
31.13.24.1213";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}