$re = '/^31\.13\.24\.0$|^31\.13\.24\.1$/m';
$str = '31.13.24.0
31.13.24.1s
31.13.24.1
sda
31.13.24.1213';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);