# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\[\[((?:(?!\[\[)[^()])*)\s+\(((?:(?!\[\[)[^()])*)\)\|(.*?)]]/{{<template>|$1|$2}}/gm;t' <<< "[[<name> (<identifier>)|<name>]]
>>>
{{<template>|<link>|<identifier>}}
====[[<link #1>]] [[<link #2 name> (<link #2 identifier>)|<link #2 name>]]====
[[<link #3 name> (<link #3 identifier>)|<link #3 name>]]"