import Foundation
let pattern = #"\[\[((?:(?!\[\[)[^()])*)\s+\(((?:(?!\[\[)[^()])*)\)\|(.*?)]]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
[[<name> (<identifier>)|<name>]]
>>>
{{<template>|<link>|<identifier>}}
====[[<link #1>]] [[<link #2 name> (<link #2 identifier>)|<link #2 name>]]====
[[<link #3 name> (<link #3 identifier>)|<link #3 name>]]
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"{{<template>|$1|$2}}"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)