const regex = /\[\[((?:(?!\[\[)[^()])*)\s+\(((?:(?!\[\[)[^()])*)\)\|(.*?)]]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[\\[((?:(?!\\[\\[)[^()])*)\\s+\\(((?:(?!\\[\\[)[^()])*)\\)\\|(.*?)]]', 'gm')
const str = `[[<name> (<identifier>)|<name>]]
>>>
{{<template>|<link>|<identifier>}}
====[[<link #1>]] [[<link #2 name> (<link #2 identifier>)|<link #2 name>]]====
[[<link #3 name> (<link #3 identifier>)|<link #3 name>]]`;
const subst = `{{<template>|$1|$2}}`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);