# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\[\[((?:(?!\[\[)[^()])*)\s+\(((?:(?!\[\[)[^()])*)\)\|(.*?)]]"
test_str = ("[[<name> (<identifier>)|<name>]]\n"
">>>\n"
"{{<template>|<link>|<identifier>}}\n\n"
"====[[<link #1>]] [[<link #2 name> (<link #2 identifier>)|<link #2 name>]]====\n"
"[[<link #3 name> (<link #3 identifier>)|<link #3 name>]]")
subst = "{{<template>|$1|$2}}"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.