using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[\[((?:(?!\[\[)[^()])*)\s+\(((?:(?!\[\[)[^()])*)\)\|(.*?)]]";
string substitution = @"{{<template>|$1|$2}}";
string input = @"[[<name> (<identifier>)|<name>]]
>>>
{{<template>|<link>|<identifier>}}
====[[<link #1>]] [[<link #2 name> (<link #2 identifier>)|<link #2 name>]]====
[[<link #3 name> (<link #3 identifier>)|<link #3 name>]]";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}