use strict;
my $str = '[[<name> (<identifier>)|<name>]]
>>>
{{<template>|<link>|<identifier>}}
====[[<link #1>]] [[<link #2 name> (<link #2 identifier>)|<link #2 name>]]====
[[<link #3 name> (<link #3 identifier>)|<link #3 name>]]';
my $regex = qr/\[\[((?:(?!\[\[)[^()])*)\s+\(((?:(?!\[\[)[^()])*)\)\|(.*?)]]/mp;
my $subst = '{{<template>|$1|$2}}';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";