#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\[\[((?:(?!\[\[)[^()])*)\s+\(((?:(?!\[\[)[^()])*)\)\|(.*?)]]"
Local $sString = "[[<name> (<identifier>)|<name>]]" & @CRLF & _
">>>" & @CRLF & _
"{{<template>|<link>|<identifier>}}" & @CRLF & _
"" & @CRLF & _
"====[[<link #1>]] [[<link #2 name> (<link #2 identifier>)|<link #2 name>]]====" & @CRLF & _
"[[<link #3 name> (<link #3 identifier>)|<link #3 name>]]"
Local $sSubst = "{{<template>|$1|$2}}"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)