import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[\\[((?:(?!\\[\\[)[^()])*)\\s+\\(((?:(?!\\[\\[)[^()])*)\\)\\|(.*?)]]";
final String string = "[[<name> (<identifier>)|<name>]]\n"
+ ">>>\n"
+ "{{<template>|<link>|<identifier>}}\n\n"
+ "====[[<link #1>]] [[<link #2 name> (<link #2 identifier>)|<link #2 name>]]====\n"
+ "[[<link #3 name> (<link #3 identifier>)|<link #3 name>]]";
final String subst = "{{<template>|$1|$2}}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}