#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)useFsFlag[(](?:\s*(".*"),\s*(".*\s*[^"]*"|[^)]*))\s*[)]"
Local $sString = " const backgroundColorFlag = useFsFlag("backgroundColor", "green")" & @CRLF & _
" const btnColorFlag = useFsFlag("btnColor", red)" & @CRLF & _
" const backgroundSize = useFsFlag("backgroundColor", 16).getValue()" & @CRLF & _
" const backgroundSize = useFsFlag("backgroundColor", 16.5).getValue()" & @CRLF & _
" const showBtn = useFsFlag("showBtn", true).getValue()" & @CRLF & _
" const showBtn = useFsFlag("showBtn",true)" & @CRLF & _
" const showBtn = useFsFlag("showBtn", "Blue, red") " & @CRLF & _
" const showBtn = useFsFlag("showBtn", "(Blue )[@)à.""h""ere)").getValue()" & @CRLF & _
" const showBtn = useFsFlag(" & @CRLF & _
" "showBtn"," & @CRLF & _
" "(Blue )he{}re)"" & @CRLF & _
" ) //comment" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")