$re = '`useFsFlag[(](?:\s*(".*"),\s*(".*\s*[^"]*"|[^)]*))\s*[)]`m';
$str = ' const backgroundColorFlag = useFsFlag("backgroundColor", "green")
const btnColorFlag = useFsFlag("btnColor", red)
const backgroundSize = useFsFlag("backgroundColor", 16).getValue()
const backgroundSize = useFsFlag("backgroundColor", 16.5).getValue()
const showBtn = useFsFlag("showBtn", true).getValue()
const showBtn = useFsFlag("showBtn",true)
const showBtn = useFsFlag("showBtn", "Blue, red")
const showBtn = useFsFlag("showBtn", "(Blue )[@)à.""h""ere)").getValue()
const showBtn = useFsFlag(
"showBtn",
"(Blue )he{}re)"
) //comment
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);