// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)useFsFlag[(](?:\s*(".*"),\s*(".*\s*[^"]*"|[^)]*))\s*[)]"#).unwrap();
let string = " const backgroundColorFlag = useFsFlag(\"backgroundColor\", \"green\")
const btnColorFlag = useFsFlag(\"btnColor\", red)
const backgroundSize = useFsFlag(\"backgroundColor\", 16).getValue()
const backgroundSize = useFsFlag(\"backgroundColor\", 16.5).getValue()
const showBtn = useFsFlag(\"showBtn\", true).getValue()
const showBtn = useFsFlag(\"showBtn\",true)
const showBtn = useFsFlag(\"showBtn\", \"Blue, red\")
const showBtn = useFsFlag(\"showBtn\", \"(Blue )[@)à.\"\"h\"\"ere)\").getValue()
const showBtn = useFsFlag(
\"showBtn\",
\"(Blue )he{}re)\"
) //comment
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}