use strict;
my $str = ' const backgroundColorFlag = useFsFlag("backgroundColor", "green")
const btnColorFlag = useFsFlag("btnColor", red)
const backgroundSize = useFsFlag("backgroundColor", 16).getValue()
const backgroundSize = useFsFlag("backgroundColor", 16.5).getValue()
const showBtn = useFsFlag("showBtn", true).getValue()
const showBtn = useFsFlag("showBtn",true)
const showBtn = useFsFlag("showBtn", "Blue, red")
const showBtn = useFsFlag("showBtn", "(Blue )[@)à.""h""ere)").getValue()
const showBtn = useFsFlag(
"showBtn",
"(Blue )he{}re)"
) //comment
';
my $regex = qr`useFsFlag[(](?:\s*(".*"),\s*(".*\s*[^"]*"|[^)]*))\s*[)]`mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}