import Foundation
let pattern = #"useFsFlag[(](?:\s*(".*"),\s*(".*\s*[^"]*"|[^)]*))\s*[)]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
const backgroundColorFlag = useFsFlag("backgroundColor", "green")
const btnColorFlag = useFsFlag("btnColor", red)
const backgroundSize = useFsFlag("backgroundColor", 16).getValue()
const backgroundSize = useFsFlag("backgroundColor", 16.5).getValue()
const showBtn = useFsFlag("showBtn", true).getValue()
const showBtn = useFsFlag("showBtn",true)
const showBtn = useFsFlag("showBtn", "Blue, red")
const showBtn = useFsFlag("showBtn", "(Blue )[@)à.""h""ere)").getValue()
const showBtn = useFsFlag(
"showBtn",
"(Blue )he{}re)"
) //comment
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)