const regex = new RegExp('useFsFlag[(](?:\\s*(".*"),\\s*(".*\\s*[^"]*"|[^)]*))\\s*[)]', 'gm')
const str = ` const backgroundColorFlag = useFsFlag("backgroundColor", "green")
const btnColorFlag = useFsFlag("btnColor", red)
const backgroundSize = useFsFlag("backgroundColor", 16).getValue()
const backgroundSize = useFsFlag("backgroundColor", 16.5).getValue()
const showBtn = useFsFlag("showBtn", true).getValue()
const showBtn = useFsFlag("showBtn",true)
const showBtn = useFsFlag("showBtn", "Blue, red")
const showBtn = useFsFlag("showBtn", "(Blue )[@)à.""h""ere)").getValue()
const showBtn = useFsFlag(
"showBtn",
"(Blue )he{}re)"
) //comment
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}