import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "useFsFlag[(](?:\\s*(\".*\"),\\s*(\".*\\s*[^\"]*\"|[^)]*))\\s*[)]";
final String string = " const backgroundColorFlag = useFsFlag(\"backgroundColor\", \"green\")\n"
+ " const btnColorFlag = useFsFlag(\"btnColor\", red)\n"
+ " const backgroundSize = useFsFlag(\"backgroundColor\", 16).getValue()\n"
+ " const backgroundSize = useFsFlag(\"backgroundColor\", 16.5).getValue()\n"
+ " const showBtn = useFsFlag(\"showBtn\", true).getValue()\n"
+ " const showBtn = useFsFlag(\"showBtn\",true)\n"
+ " const showBtn = useFsFlag(\"showBtn\", \"Blue, red\") \n"
+ " const showBtn = useFsFlag(\"showBtn\", \"(Blue )[@)à.\"\"h\"\"ere)\").getValue()\n"
+ " const showBtn = useFsFlag(\n"
+ " \"showBtn\",\n"
+ " \"(Blue )he{}re)\"\n"
+ " ) //comment\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}