# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"useFsFlag[(](?:\s*(\".*\"),\s*(\".*\s*[^\"]*\"|[^)]*))\s*[)]"
test_str = (" const backgroundColorFlag = useFsFlag(\"backgroundColor\", \"green\")\n"
" const btnColorFlag = useFsFlag(\"btnColor\", red)\n"
" const backgroundSize = useFsFlag(\"backgroundColor\", 16).getValue()\n"
" const backgroundSize = useFsFlag(\"backgroundColor\", 16.5).getValue()\n"
" const showBtn = useFsFlag(\"showBtn\", true).getValue()\n"
" const showBtn = useFsFlag(\"showBtn\",true)\n"
" const showBtn = useFsFlag(\"showBtn\", \"Blue, red\") \n"
" const showBtn = useFsFlag(\"showBtn\", \"(Blue )[@)à.\"\"h\"\"ere)\").getValue()\n"
" const showBtn = useFsFlag(\n"
" \"showBtn\",\n"
" \"(Blue )he{}re)\"\n"
" ) //comment\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.