using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^msgstr (?:""[^""\r\n]+""|.*(?:\n"".*"")+)";
string input = @"msgstr ""some text""
or which spread on several lines:
msgstr ""
""some multiline text""
""goes here""
but not empty ones:
msgstr """;
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}