const regex = /^msgstr (?:"[^"\r\n]+"|.*(?:\n".*")+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^msgstr (?:"[^"\\r\\n]+"|.*(?:\\n".*")+)', 'gm')
const str = `msgstr "some text"
or which spread on several lines:
msgstr ""
"some multiline text"
"goes here"
but not empty ones:
msgstr ""`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}