re = /^msgstr (?:"[^"\r\n]+"|.*(?:\n".*")+)/m
str = 'msgstr "some text"
or which spread on several lines:
msgstr ""
"some multiline text"
"goes here"
but not empty ones:
msgstr ""'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end