package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^msgstr (?:"[^"\r\n]+"|.*(?:\n".*")+)`)
var str = `msgstr "some text"
or which spread on several lines:
msgstr ""
"some multiline text"
"goes here"
but not empty ones:
msgstr ""`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}