import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^msgstr (?:\"[^\"\\r\\n]+\"|.*(?:\\n\".*\")+)";
final String string = "msgstr \"some text\"\n"
+ "or which spread on several lines:\n\n"
+ "msgstr \"\"\n"
+ "\"some multiline text\"\n"
+ "\"goes here\"\n\n\n"
+ "but not empty ones:\n\n"
+ "msgstr \"\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}