// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)^msgstr (?:"[^"\r\n]+"|.*(?:\n".*")+)"#).unwrap();
let string = "msgstr \"some text\"
or which spread on several lines:
msgstr \"\"
\"some multiline text\"
\"goes here\"
but not empty ones:
msgstr \"\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}