import re
regex = re.compile(r"^msgstr (?:\"[^\"\r\n]+\"|.*(?:\n\".*\")+)", flags=re.MULTILINE)
test_str = ("msgstr \"some text\"\n"
"or which spread on several lines:\n\n"
"msgstr \"\"\n"
"\"some multiline text\"\n"
"\"goes here\"\n\n\n"
"but not empty ones:\n\n"
"msgstr \"\"")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")