$re = '/^msgstr (?:"[^"\r\n]+"|.*(?:\n".*")+)/m';
$str = 'msgstr "some text"
or which spread on several lines:
msgstr ""
"some multiline text"
"goes here"
but not empty ones:
msgstr ""';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);