# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:(?<=\S)( )+)? *remove *(?(1) (?=\S)(?!remove\b))/\1/gm;t' <<< "before remove after
before remove after
remove after
before remove
before remove
remove
remove
remove
before remove after remove before
before remove after remove before remove
before remove after remove before remove
before remove after remove before before remove remove remove
remove remove remove "