import re
regex = re.compile(r"(?:(?<=\S)( )+)? *remove *(?(1) (?=\S)(?!remove\b))", flags=re.MULTILINE)
test_str = ("before remove after\n"
"before remove after\n"
"remove after\n"
"before remove\n"
"before remove\n"
"remove\n"
" remove \n"
"remove \n"
"before remove after remove before\n"
"before remove after remove before remove\n"
"before remove after remove before remove \n"
"before remove after remove before before remove remove remove\n"
"remove remove remove ")
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)