const regex = new RegExp('(?:(?<=\\S)( )+)? *remove *(?(1) (?=\\S)(?!remove\\b))', 'gm')
const str = `before remove after
before remove after
remove after
before remove
before remove
remove
remove
remove
before remove after remove before
before remove after remove before remove
before remove after remove before remove
before remove after remove before before remove remove remove
remove remove remove `;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);