import Foundation
let pattern = #"(?:(?<=\S)( )+)? *remove *(?(1) (?=\S)(?!remove\b))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
before remove after
before remove after
remove after
before remove
before remove
remove
remove
remove
before remove after remove before
before remove after remove before remove
before remove after remove before remove
before remove after remove before before remove remove remove
remove remove remove
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)