$re = '/(?:(?<=\S)( )+)? *remove *(?(1) (?=\S)(?!remove\b))/m';
$str = 'before remove after
before remove after
remove after
before remove
before remove
remove
remove
remove
before remove after remove before
before remove after remove before remove
before remove after remove before remove
before remove after remove before before remove remove remove
remove remove remove ';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;