#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:(?<=\S)( )+)? *remove *(?(1) (?=\S)(?!remove\b))"
Local $sString = "before remove after" & @CRLF & _
"before remove after" & @CRLF & _
"remove after" & @CRLF & _
"before remove" & @CRLF & _
"before remove" & @CRLF & _
"remove" & @CRLF & _
" remove " & @CRLF & _
"remove " & @CRLF & _
"before remove after remove before" & @CRLF & _
"before remove after remove before remove" & @CRLF & _
"before remove after remove before remove " & @CRLF & _
"before remove after remove before before remove remove remove" & @CRLF & _
"remove remove remove "
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)