re = /(?:(?<=\S)( )+)? *remove *(?(1) (?=\S)(?!remove\b))/m
str = 'before remove after
before remove after
remove after
before remove
before remove
remove
remove
remove
before remove after remove before
before remove after remove before remove
before remove after remove before remove
before remove after remove before before remove remove remove
remove remove remove '
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result