# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\d{4}-\d{2}-\d{2})Z/$1/gm;t' <<< "control1970-04-26Z_shifted1982-02-01_Zulu1999-09-09Z"