#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\d{4}-\d{2}-\d{2})Z"
Local $sString = "control1970-04-26Z_shifted1982-02-01_Zulu1999-09-09Z"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)