re = /(\d{4}-\d{2}-\d{2})Z/m
str = 'control1970-04-26Z_shifted1982-02-01_Zulu1999-09-09Z'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result